Computing & Communications Center
Helpdesk

Obtaining E-Mail Headers

If you would like to report a potentially virus-generated e-mail to the Helpdesk to investigate, please forward us the e-mail header information by following the appropriate instructions below.

Choose an e-mail program...
Outlook 2003 Outlook 2007 Outlook Web Access
Outlook Express Pine Elm
Apple Mail Eudora Mutt
Pegasus Netscape Thunderbird

Outlook 2003

  1. Click on the appropriate message so that it is highlighted.
  2. Right click on this message.
  3. Pick Options from this menu.
  4. Copy all of the information in the box labeled Internet Headers. (Click once inside of this box and press ctrl+A to highlight everything, then copy.)
  5. Paste this information into a new email to the requester.

Return to Top

Outlook 2007

  1. Click on the appropriate message so that it is highlighted.
  2. Right click on this message.
  3. Pick Message Options from this menu.
  4. Copy all of the information in the box labeled Internet Headers. (Click once inside of this box and press ctrl+A to highlight everything, then copy.)
  5. Paste this information into a new email to the requester.

Return to Top

Outlook Express

  1. Double-click on the appropriate e-mail message.
  2. Select Properties from the File menu.
  3. Click on the Details tab.
  4. Copy all of the headers and paste them into a new e-mail to send to the requester.

Return to Top

Outlook Web Access (Internet Explorer)

  1. Double click on the appropriate message
  2. Click on the icon labeled Message Details located to the left of the printer icon.
  3. Copy all of the information in the box labeled Internet Headers. (Click once inside of this box and press ctrl+A to highlight everything, then copy.)
  4. Paste this information into a new email to the requester.

Return to Top

Pine

  1. From the Main Menu in Pine, press S for Setup, and then C for Configure.
  2. Move down through the list of options under feature-list until you reach enable-full-header-cmd. (The feature list is arranged alphabetically.) Press X to make an X appear in the box next to that option.
  3. Press E for Exit Config, and then Y for Yes when Pine asks if you wish to save the changes to your configuration.
  4. Now, whenever you want to forward a given message with full headers, you can press H while viewing the message (so that all headers appear on your screen), and then forward as usual.

Return to Top

Apple Mail (not supported)

  1. Click on the appropriate message
  2. Click the View menu, then choose Message and Long Headers
  3. Copy all of the headers and paste them into a new e-mail to send to the requester.

Return to Top

Elm (not supported)

  1. While viewing the message you wish to forward, press H to show full headers.
  2. Press S to save the message to a file, and then type any filename you like. Elm will then acknowledge the save and return you to the message index.
  3. Open a new email to the requester and insert the file you saved. (If you are using Emacs, the command is CTRL-X I. In Pico, the command it CTRL-R. In vi, the command is ESC:r "filename".)
  4. Then send the mail message.

Return to Top

Mutt (not supported)

Older versions of Mutt handle headers beautifully: no muss, no fuss. Press h to view the headers, then f to forward the message. That's it!

In newer versions of Mutt, your mime_forward variable must be unset. This is the default on most, but not all, systems. If forwarding a message does not put the full headers in the body, check that variable in your .muttrc.

Return to Top

Eudora (not supported)

For Eudora Light (1.5.2 or lower for the PC, 1.5.4 or lower for the Mac) or Eudora Pro (lower than 2.0.2)

In Light versions 1.5.2 and below for the PC, 1.5.4 and below for the Mac, or Pro 2.0.2 and below, you can view the full headers but the program will not forward them--you will have to cut and paste the headers.

  1. Select Special from the menu bar, and then Settings from the menu given.
  2. Scroll down until you see Fonts & Display, and click on that item.
  3. From the list of settings that appears on the right side of the dialogue box, click on the box next to Show all headers (even the ugly ones). An X should appear in the box.
  4. Click on the OK button to save the settings.
  5. Now, when you view a message, the full headers will be visible. To include them in mail you send out, highlight the lines with your mouse, and select Copy from the Edit menu; then, while composing your outgoing message, select Paste from the Edit menu.

For Eudora Light (1.5.4 for Windows)

Follow the instructions above for 1.5.2, but for step 1, select Options from the Tools menu.

For Eudora Light or Pro (3.0 and newer)

  1. While viewing a message, you will see a button that says "Blah blah blah" (no, really!) in the upper left-hand corner of the message window. Click it to turn on full headers.
  2. While the full headers are visible, just forward the message; they will be reproduced in the outgoing mail.

Return to Top

Pegasus (not supported)

  1. While viewing a message, go to the Reader menu and select Show All Headers.
  2. Highlight the headers with the mouse and select Copy from the Edit menu; then, while composing your outgoing message, select Paste from the Edit menu.

Return to Top

Netscape (not supported)

Netscape 3

  1. In Netscape Mail, go to the Options menu and choose Show Headers.
  2. Then select All.
  3. When you return to the message, you'll see all the headers. Just forward the mail (as an attachment, which is the default).

Netscape Communicator

  1. Go to the View menu.
  2. Select Headers.
  3. Choose All.
  4. Forward the message as an attachment.

Return to Top

Thunderbird (not supported)

  1. In Thunderbird, go to the View menu and select Headers, then All.
  2. Forward the message to the requester.

Return to Top

If you have any questions regarding this procedure, please contact the Helpdesk for clarification.

Maintained by itweb.
Last modified: Nov 20, 2008, 15:34 EST
[WPI] [Home] [Back]